Packages

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug report
  • Category core
  • Assigned To No-one
  • Operating System
  • Severity High
  • Priority Normal
  • Reported Version Stable
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 0
  • Private No
Attached to Project: Packages
Opened by Claudio Maradonna (sparmi) - 2016-01-14

FS#1332 - vgaarb: this pci device is not a vga device

Description:
Bumblebee started, i tried to run simply 'optirun glxspheres' and all worked; but when i closed window, all my screen goes black with mouse over.
I think nvidia driver can't get screen correctly for some reason.
Later i've found that in dmesg.

Additional information:
* linux: 4.2.6-1-CHAKRA
* nvidia: 358.16-2
* bumblebee: 3.2.1-8
* no special config

Nvidia 960M + Intel i7 6700HQ with Intel VGA

Steps to reproduce:
* Follow official guide for Bumblebee https://chakraos.org/wiki/index.php?title=Bumblebee
* reboot and try 'optirun glxspheres' or 'primusrun glxspheres'

Actual result:
In dmesg: vgaarb: this pci device is not a vga device
I get a black screen and i need to enter tty2 and kill X server.

Expected result:
Exec glxspheres with dedicated VGA and stop. No black screen, no stop X server.

This task does not depend on any other tasks.

Luca Giambonini (AlmAck)
Tuesday, 26 January 2016, 20:50 GMT
I found this bug upstream:
https://github.com/Bumblebee-Project/Bumblebee/issues/159
http://forum.siduction.org/index.php?topic=5104.0

You confirm that you still have this bug? how is the severity? you can use chakra?
Claudio Maradonna (sparmi)
Wednesday, 27 January 2016, 18:00 GMT
I tested now and black screen is solved but the message: "vgaarb: this pci device is not a vga device" is yet present.
I think that this message is not related to black screen but i don't understand now why i had xorg stopped later optirun.
Bruce Liu (brli)
Thursday, 26 May 2016, 17:42 GMT
does it fix with linux 4.5.1-3?
Claudio Maradonna (sparmi)
Friday, 27 May 2016, 20:37 GMT
I synced repos, but i cannot install 4.5.1-3 at the moment, i'll try when available on download :)
Claudio Maradonna (sparmi)
Saturday, 13 August 2016, 09:38 GMT
Ok, same with kernel -> 4.5.7-1-CHAKRA

Later run `optirun glxspheres` i have a black screen, i pressed together CTRL and ALT and my desktop appeared LoL.
Francesco Marinucci (FranzMari)
Thursday, 30 March 2017, 13:26 GMT
Is this still valid in Goedel?

Loading...